• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Xoom completely dead. HELP!!

This is a discussion on Xoom completely dead. HELP!! within the Honeycomb General Discussion forums, part of the Motorola Xoom Honeycomb Forum category; My Xoom 3G just won't turn on. I've tried everything - holding power button, soft reset (holding power+up for up to 3 minutes), holding power+down, ...

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    Xoom Lurker
    Member #
    23502
    Join Date
    May 2012
    Posts
    16
    Liked
    0 times

    Angry Xoom completely dead. HELP!!

    My Xoom 3G just won't turn on.
    I've tried everything - holding power button, soft reset (holding power+up for up to 3 minutes), holding power+down, tapping up while holding power. I've tried all of the above mentioned methods when it's not completely charged, when it's completely charged, and when it's left charged overnight. I've tried them with AC plugged and unplugged. Still it's completely dead. Nothing will appear on the screen, not even the Motorolla or the "dual core" logos.

    It started to behave like this a couple of weeks ago, when it was running 3.1 (maybe it was a bad app I installed.) When it was turned off, it always required a soft reset to turn it on, sometimes it required a few attempts. When 3.2 update came, I thought it would fix this issue. But when the OS finished updating and restarted, as usual, it wouldn't turn on and required soft reset. The problem persisted until a couple of days ago, when nothing would work.

    I would do a hard reset but I can't even turn it on! Is there any way to do with with the hardware? I have no problem taking it apart.

    Please help! There's nowhere else to go.
    Thanks guys!

  2. # ADS
    Ads


  3. #2
    Rescue Squad

    Member #
    608
    Join Date
    Mar 2011
    Location
    EARTH
    Posts
    14,459
    Liked
    284 times
    holding the volume up and power button does nothing correct?

    does the charging light come on either white,or green?

    have you checked your charger to make sure it is working?
    <img src=http://www.xoomforums.com/forum/signaturepics/sigpic608_2.gif border=0 alt= />
    Never Fear the iOwl is Here

  4. #3
    Xoom Ninja
    Member #
    22220
    Join Date
    Mar 2012
    Location
    Sheboygan, WI
    Posts
    4,194
    Liked
    81 times
    Twitter
    Ben_J_H
    My buddy Pharaoh could of welcomed you haha...... WELCOME! GLAD you decided to join us here! Enjoy!

    Sent from my XOOM 2 using Xparent Green Tapatalk 2

  5. #4
    Xoom Lurker
    Member #
    23502
    Join Date
    May 2012
    Posts
    16
    Liked
    0 times
    Quote Originally Posted by Pharoah View Post
    holding the volume up and power button does nothing correct?

    does the charging light come on either white,or green?

    have you checked your charger to make sure it is working?

    Thanks for your reply!
    That is correct, volume up and power button does nothing.
    Yes. The light is white when it's not completely charged, and green when it's completely charged.
    I've even opened up the case, disconnected the battery connection to the AC. When the battery is disconnected, there's no LED light from the battery indicator, when it's reconnected, there is light. So ya the charger is working.

  6. #5
    Xoom Lurker
    Member #
    23502
    Join Date
    May 2012
    Posts
    16
    Liked
    0 times
    Quote Originally Posted by Ben.J.H View Post
    My buddy Pharaoh could of welcomed you haha...... WELCOME! GLAD you decided to join us here! Enjoy!

    Sent from my XOOM 2 using Xparent Green Tapatalk 2
    Thanks! It's no problem, Pharoah jumped right into helping!
    Gotta love my title "xoom lurker".

  7. #6
    Rescue Squad

    Member #
    608
    Join Date
    Mar 2011
    Location
    EARTH
    Posts
    14,459
    Liked
    284 times
    has the unit been dropped,or anything else that may cause damage?how long have you had this unit?is this an ebay,or craigslist purchased item?
    <img src=http://www.xoomforums.com/forum/signaturepics/sigpic608_2.gif border=0 alt= />
    Never Fear the iOwl is Here

  8. #7
    Administrator

    Member #
    2101
    Join Date
    Mar 2011
    Location
    Wichita Falls
    Posts
    35,843
    Liked
    2223 times
    Twitter
    mgrant76308
    Quote Originally Posted by 1k1k1k View Post
    Thanks for your reply!
    That is correct, volume up and power button does nothing.
    Yes. The light is white when it's not completely charged, and green when it's completely charged.
    I've even opened up the case, disconnected the battery connection to the AC. When the battery is disconnected, there's no LED light from the battery indicator, when it's reconnected, there is light. So ya the charger is working.
    Welcome to the forum. Glad you decided to join us. Put it on the charger and leave it on for 30 minutes after the charge indicator turns green and then do a soft reboot.



    Note 8
    Galaxy S8 Plus
    Nexus 6 - PureNexus

  9. #8
    Xoom Lurker
    Member #
    23502
    Join Date
    May 2012
    Posts
    16
    Liked
    0 times
    Quote Originally Posted by Pharoah View Post
    has the unit been dropped,or anything else that may cause damage?how long have you had this unit?is this an ebay,or craigslist purchased item?
    No it hasn't been dropped or anything. I'm very careful with it. I've had it since around July of last year. I bought it new from a retail store. Again, it has always been working fine until just a couple of weeks ago..

  10. #9
    Xoom Lurker
    Member #
    23502
    Join Date
    May 2012
    Posts
    16
    Liked
    0 times
    Quote Originally Posted by ggrant3876 View Post
    Welcome to the forum. Glad you decided to join us. Put it on the charger and leave it on for 30 minutes after the charge indicator turns green and then do a soft reboot.

    I left it on the charger, full charged (green light) for about 10 hours last night. Still not working =/

  11. #10
    Xoom Ninja
    Member #
    22220
    Join Date
    Mar 2012
    Location
    Sheboygan, WI
    Posts
    4,194
    Liked
    81 times
    Twitter
    Ben_J_H
    So it should still be in warranty if needed?

    Sent from my XOOM 2 using Xparent Green Tapatalk 2


 
Page 1 of 3 1 2 3 LastLast

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. i need help i think my xoom is dead
    By pralvarado in forum Motorola Xoom General Discussion
    Replies: 8
    Last Post: 12-25-2012, 07:25 AM
  2. How do I clear all User data w/o completely wiping to Xoom?
    By panzer06 in forum ICS General Discussion
    Replies: 6
    Last Post: 03-30-2012, 07:40 PM
  3. My XOOM is Dead!
    By CoolAmI in forum Motorola Xoom Help
    Replies: 4
    Last Post: 01-24-2012, 04:54 AM
  4. I am completely new to the xoom game Help
    By femedy in forum New Member Introduction & Site Assistance
    Replies: 4
    Last Post: 11-30-2011, 10:18 AM
  5. My Xoom is dead!! :-(
    By digigal in forum Xoom Rescue Squad Help
    Replies: 16
    Last Post: 09-23-2011, 03:33 AM

Search tags for this page

dead motorola zoom hard reset
,

dead xoom

,
motorola xoom battery
,

motorola xoom completely dead

,
motorola xoom tablet dead
,
motorola xoom tablet died
,
motorola xoom totally dead
,
motorola xzoom battery
,
tablet completely dead
,
www.1k1k1k.com
,
xoom completely dead
,

xoom dead

,
xoom died
,
xoom disconnect battery
,
xoom is dead
,
xoom no turn on completely discharged
,
xoom tablet dead
,
xoom tablet died
,
xoom tablet is dead
,
zoom tablet dead
Click on a term to search for related topics.

Tags for this Thread