• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

XOOM2 adhoc mode enable

This is a discussion on XOOM2 adhoc mode enable within the Motorola Xoom 2 Development forums, part of the Motorola Xoom 2 Forum category; It's about how to get internet for XOOM2 from your computer's wifi I tried to tether internet from laptop to my XOOM2 ME wifi. So, ...

Results 1 to 5 of 5
Like Tree2Likes
  • 2 Post By Jasuramme

Thread: XOOM2 adhoc mode enable

  1. #1
    Xoom Lurker
    Member #
    22968
    Join Date
    Apr 2012
    Posts
    11
    Liked
    8 times

    Talking XOOM2 adhoc mode enable

    It's about how to get internet for XOOM2 from your computer's wifi
    I tried to tether internet from laptop to my XOOM2 ME wifi. So, I've got it.
    I believe, it should work on other XOOM2s.
    It working through adhoc wifi network, so now you could connect to adhoc networks.

    There's lazyman solution in post#4 I tried to do it as simple as i can
    Easy way: XOOM2 adhoc mode enable


    and there's smaurai way:
    There's solution:
    1 You need rooted XOOM2 (i used Dan's one click way. Thanks to him )
    2 After that you need iwconfig utility. You can push it to your xoom through adb, for expample (adb push iwconfig /sdcard
    3Then you have to move iwconfig to your /system/bin directory. On some guides I've seen, that you can do it with root explorer. I did it through terminal emulator.

    For terminal emulator
    su #getting superuser
    mount -o remount,rw /system #get ability to write to /system folder
    cp /sdcard/iwconfig /system/bin/

    4 you need to give iwconfig 755 permissions. Through terminal you can do:

    chmod 755 /system/bin/iwconfig

    You can also do it through root explorer, but you have to find how.

    5 Ummm... Actually it should work as "iwconfig tiwlan0 mode ad-hoc essid YOUR_ADHOCNETWORK_SSID"
    but i like to use ghostscript better. so

    -PROBABLY OPTIONAL-

    6 install ghostscript lite from market.

    7 create script. In /system/bin again

    touch /system/bin/netwifi

    8 write script itself

    i did it through vi editor in emulator

    vi /system/bin/netwifi

    if you don't know vi, do it with another tools or read wiki

    you have to write here as follows

    iwconfig tiwlan0 mode ad-hoc essid YOUR_ADHOCNETWORK_SSID

    9 add 755 permissions to your script

    chmod 755 /system/bin/netwifi

    10 add this script to ghostscript open ghostscript. Create new script. Give it name, and thick need SU and below you write /system/bin/netwifi

    So, that's it. When you run this script it should connect to your network.
    Just in case. I did it on my XOOM2 ME wifi. I hadn't got iwconfig utility. To ensure what you're doing, you have to check don't you have /system/bin/iwconfig already.

    What we actually did?
    we got iwconfig - that's linux utility to connect to wifi.
    installed ghost script - just to start this wifi utility with one click.
    That's it. Not so much. It's looks harder than it is.
    It rebooted few times before it starts to work. But it was probably because I tried to use more then one adhoc programs in one time.
    I don't think it can damage your XOOM2, but anyway, you do it on your own risk
    For some reason I couldn't upload iwconfig i used. I will send link in next post
    It can be issue that your driver not tiwlan0 on other devices. But it will basicly just give error. Just post it here, we will update this guide.
    You don't modify any android core files. You just add new. All should be ok.

    Good luck
    Last edited by Jasuramme; 05-27-2012 at 04:43 PM. Reason: added easy solution to do this
    ggrant3876 and HussX like this.

  2. # ADS
    Ads


  3. #2
    Xoom Lurker
    Member #
    22968
    Join Date
    Apr 2012
    Posts
    11
    Liked
    8 times
    Iwconfig is here: DepositFiles

    If it too long, maybe we can do adb script for that
    Last edited by Jasuramme; 05-27-2012 at 03:28 AM.

  4. #3
    Administrator

    Member #
    2101
    Join Date
    Mar 2011
    Location
    Wichita Falls
    Posts
    35,844
    Liked
    2223 times
    Twitter
    mgrant76308
    Nice work, thanks for sharing with us.



    Note 8
    Galaxy S8 Plus
    Nexus 6 - PureNexus

  5. #4
    Xoom Lurker
    Member #
    22968
    Join Date
    Apr 2012
    Posts
    11
    Liked
    8 times
    Guys, I made lazy man installer.
    How to install this stuff
    I'll try to write every smallest step in guide
    It's supposed that name of your network is XOOM2_adhoc if you want to use another name, change it in the secondstage.sh file

    0. Root your XOOM2
    1. on your XOOM2 go to Settings->applications->development and thick debugging via usb
    2. Get adb tool to your computer (it's originally from android SDK)
    3 unzip adhoc.zip archive to folder, where adb tool situated in
    4 start adhoc script (for windows - just start adhoc.bat, for ubuntu start terminal and go to adb folder then:
    sudo chmod 777 ./adhoc.sh
    ./adhoc.sh
    5 you should be in XOOM2 shell at this moment. type
    su
    sh /sdcard/secondstage.sh
    exit
    exit
    6 install ghostscript light on your XOOM2
    7 open ghostscript. Create new script. Give it name, and thick need SU and below you write /system/bin/netwifi
    8 Then create wifi network with your session id on computer, start this script on your XOOM2 and it should connect;

    So, it's installed. Everytime to connect you just open this script in ghostscript

    adhoc scripts and adb tool are in attachment
    There actually not only adb in archive. All platform-tools from SDK. But what important - adb os inside

    and again

    You do it on your own risk!

    adb for windows:
    DepositFiles


    adb for linux:
    http://depositfiles.com/files/v76otiwq0

    Updated first post


    Attached Files Attached Files
    Last edited by Jasuramme; 05-28-2012 at 12:49 AM.

  6. #5
    Xoom Lurker
    Member #
    24979
    Join Date
    Jul 2012
    Posts
    12
    Liked
    0 times
    Hi ! I'm new to Andriod. I need to connect my phone. I've tried the above and I face the following difficulty:

    1. I can't find the ghostscript in Play Store. I searched for it but I couldn't find it.
    2. I search and found some commands which I put together..

    su #getting superuser
    mount -o remount,rw /system #get ability to write to /system folder
    iwconfig tiwlan0 mode auto essid any

    I managed to connect to my phone but only in SECURITY=NONE (but I guess it's nothing to do with the commands). I can only issue the commands in ADB. If I restart my Xoom, how to get the commands to be executed without ghostscript ?

    I guess these are very simple.. but I really need your help and thanks very much in advance !


 

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Xoom2 Won't turn on?
    By olgunozcan in forum Motorola Xoom 2
    Replies: 14
    Last Post: 06-07-2012, 02:25 PM
  2. Problem connecting Xoom2 me to XP box
    By g2c in forum Motorola Xoom Help
    Replies: 1
    Last Post: 12-22-2011, 03:36 AM
  3. Less RAM on Xoom2?
    By ANATELConsult in forum Motorola Xoom 2
    Replies: 15
    Last Post: 11-16-2011, 12:51 PM
  4. No internet with adhoc
    By llt_droid in forum Motorola Xoom Development
    Replies: 0
    Last Post: 10-01-2011, 06:08 PM
  5. Adhoc networks and 3.1 update
    By celticxoom in forum Motorola Xoom WiFi General Discussion
    Replies: 1
    Last Post: 06-08-2011, 07:30 AM

Search tags for this page

ad hoc network on xoom

,

ad hoc xoom 2

,
how to activate ad hoc network in motorola
,
how to activate network on xoom 2
,

how to connect xoom 2 ad hoc

,

how to install ghostscript in xoom 2

,
htc le ad hoc mode
,

motorola xoom 2 ad-hoc

,

motorola xoom 2 ad-hoc networks

,

motorola xoom ad hoc wifi

,

wifi ad hoc enabler no xoom 2

,

xoom 2 ad hoc

,

xoom 2 ad hoc wifi

,

xoom 2 ad-hoc

,
xoom 2 adhoc issue
,

xoom 2 adhoc iwconfig

,

xoom 2 adhoc wifi

,

xoom 2 wifi adhoc connect

,

xoom ad hoc wifi

,

xoom ics ad hoc

Click on a term to search for related topics.

Tags for this Thread