• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Mount Internal Storage in Ubuntu

This is a discussion on Mount Internal Storage in Ubuntu within the Motorola Xoom Development forums, part of the Motorola Xoom Hacks category; Originally Posted by grenness OK, so I have everything working thanks to this thread, except the most important thing - copying files to the Xoom. ...

Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 24
Like Tree2Likes

Thread: Mount Internal Storage in Ubuntu

  1. #11
    Xoom Pursuant
    Member #
    2058
    Join Date
    Mar 2011
    Posts
    647
    Liked
    40 times
    Quote Originally Posted by grenness View Post
    OK, so I have everything working thanks to this thread, except the most important thing - copying files to the Xoom.
    What happens is that when I copy a single or several files using Nautilus (default GUI file manager in Ubuntu 10.10) as soon as the files seems to have been copied 100% they just disappear on the Xoom. Just like that.
    Trying to do a cp in terminal gets me this:

    Code:
    christopher@maranello:~/Desktop$ cp test.txt /media/xoom
    christopher@maranello:~/Desktop$
    no error messages at all, but browsing the root folder of the Xoom shows me that there's no test.txt file there...


    Any help would be highly appreciated!

    Regards,
    Christopher

    2.6.35-28-generic-pae #50-Ubuntu SMP Fri Mar 18 20:43:15 UTC 2011 i686 GNU/Linux
    When it was working for me, i had this issue too. I just copied it over a second time and it worked.

    Sent from my Xoom using Tapatalk
    Xoom Wifi - Stock ICS
    64gb Sandisk Micro SDXC (2)
    32gb Adata Micro SD (class 10 and 6)

    No need for a cloud.

  2. # ADS
    Ads


  3. #12
    Xoom Lurker
    Member #
    3425
    Join Date
    Apr 2011
    Posts
    9
    Liked
    0 times
    Quote Originally Posted by JR8203 View Post
    Although for Windows users it actually works pretty well
    Actually, as a Windows user, it was a source of great frustration to me, as the first file I tried transferring to my Xoom was a PDF eBook... which apparently isn't allowed under the MT protocol. I had never even heard of MTP before, and was pulling my hair out trying to figure out why Windows just didn't want to seem to allow me to copy a simple file over. Then I tried emailing it to myself, but K9's 'save attachment to SD' option wouldn't work because of the lack of SD support. I ended up hosting the file online and downloading through a web browser (I had not heard of DropBox yet).

  4. #13
    Xoom Lurker
    Member #
    1066
    Join Date
    Mar 2011
    Posts
    14
    Liked
    1 times
    Quote Originally Posted by MacKai View Post
    Can some one point out EXACTLY where this extra space is. Or has it already been fixed in the instructions?

    I'm looking to simply cut and paste the instruction I'm not comfortable in the Terminal

    thanks everyone

    mtpfs /media/xoom fuse user,noauto,allow_other 0 0 (Cut and paste this line to the left and you'll have it as the extra space was between the , and n

    Hope this helps

  5. #14
    Xoom Informant
    Member #
    6315
    Join Date
    May 2011
    Posts
    34
    Liked
    3 times
    It worked at first for me but after that I cannot access the xoom directory at all. I always get the error message stating "Transport endpoint is not connected". Here is a screenshot of what I see in the terminal when doing an ls of the /media directory:

    dude@lpdv72185:/media$ ls -l
    ls: cannot access xoom: Transport endpoint is not connected
    total 12
    drwx------ 1 dude dude 4096 May 24 10:30 truecrypt1
    drwx------ 2 dude dude 4096 May 9 18:45 truecrypt2
    drwx------ 2 dude dude 4096 May 20 23:03 truecrypt3
    d????????? ? ? ? ? ? xoom

    I mounted the device using "mtpfs /media/xoom -o allow_other which does not generate an error message; however, when I then run the ls -l command to see the status of the directory I see the above output. My mtab file shows the following:

    mtpfs /media/xoom fuse.mtpfs rw,nosuid,nodev,allow_other,user=dude 0 0

    Any ideas?

    I am running 64Bit Ubuntu 11.04 with Gnome 3 instead of Unity.

  6. #15
    Administrator

    Member #
    7
    Join Date
    Feb 2011
    Location
    El Paso, TX
    Posts
    6,454
    Liked
    356 times
    Twitter
    Droid_Xer
    It worked for me on maverick and natty with unity though.

    Moving to development

  7. #16
    Xoom Informant
    Member #
    6315
    Join Date
    May 2011
    Posts
    34
    Liked
    3 times
    Quote Originally Posted by onewiseguy View Post
    It worked at first for me but after that I cannot access the xoom directory at all. I always get the error message stating "Transport endpoint is not connected". Here is a screenshot of what I see in the terminal when doing an ls of the /media directory:

    dude@lpdv72185:/media$ ls -l
    ls: cannot access xoom: Transport endpoint is not connected
    total 12
    drwx------ 1 dude dude 4096 May 24 10:30 truecrypt1
    drwx------ 2 dude dude 4096 May 9 18:45 truecrypt2
    drwx------ 2 dude dude 4096 May 20 23:03 truecrypt3
    d????????? ? ? ? ? ? xoom

    I mounted the device using "mtpfs /media/xoom -o allow_other which does not generate an error message; however, when I then run the ls -l command to see the status of the directory I see the above output. My mtab file shows the following:

    mtpfs /media/xoom fuse.mtpfs rw,nosuid,nodev,allow_other,user=dude 0 0

    Any ideas?

    I am running 64Bit Ubuntu 11.04 with Gnome 3 instead of Unity.


    I figured out the problem. USB debugging must be turned on in order for it to connect. When it is turned off, I was getting the error.

  8. #17
    Xoom Lurker
    Member #
    14738
    Join Date
    Oct 2011
    Location
    Okinawa, Japan
    Posts
    3
    Liked
    0 times
    I have this working in Kubuntu 11.04 32bit. but it doesn't auto mount when I plug it in :/ I have to use the command mtpfs /media/xoom USB debugging does not have to be on for me.

  9. #18
    Xoom Lurker
    Member #
    18710
    Join Date
    Dec 2011
    Posts
    1
    Liked
    0 times
    There is a problem with this line in fstab:

    mtpfs /media/xoom fuse user, noauto,allow_other 0 0

    The space between "user," and "noauto..." is understood as a different column, and fstab expects 6 of them.

    I needed to remove that space in order to make it work.

    mtpfs /media/xoom fuse user,noauto,allow_other 0 0
    Thanks for your post anyway. It was really helpfull.


    Last edited by cubierto; 12-28-2011 at 08:14 AM.

  10. #19
    Administrator

    Member #
    2101
    Join Date
    Mar 2011
    Location
    Wichita Falls
    Posts
    35,845
    Liked
    2223 times
    Twitter
    mgrant76308
    Quote Originally Posted by cubierto View Post
    There is a problem with this line in fstab:

    The space between "user," and "noauto..." is understood as a different column, and fstab expects 6 of them.

    I needed to remove that space in order to make it work.


    Thanks for your post anyway. It was really helpfull.


    Welcome to the forum.Glad you decided to join us.



    Note 10 Plus
    OnePlus 6T


  11. #20
    Xoom Lurker
    Member #
    18764
    Join Date
    Dec 2011
    Posts
    5
    Liked
    0 times
    Hi everyone

    Sorry to resurrect an old thread, but I am currently trying to connect my UK 3G xoom to my ubuntu 10.04 pc. I have followed the instructions above exactly, however when I put "mtpfs /media/xoom -o allow_other" into the terminal it says:

    fuse: bad mount point `/media/xoom': Transport endpoint is not connected

    I have tried it with usb debugging on and off, and also tried each of the following in the fstab file, all of which result in the same error message:

    mtpfs /media/xoom fuse user,noauto,allow_other 0 0
    mtpfs /media/xoom fuse user,noauto,allow_other 0 0
    mtpfs /media/xoom fuse user, noauto, allow_other 0 0
    mtpfs /media/xoom fuse user, noauto,allow_other 0 0

    I'd be really grateful for any help you can provide as I'd like to be able to copy music and other files to and from my xoom

    Thanks


 
Page 2 of 3 FirstFirst 1 2 3 LastLast

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. GoAruna - Honeycomb Cloud Based Storage
    By CZonin in forum Motorola Xoom Apps
    Replies: 25
    Last Post: 09-10-2011, 08:53 PM
  2. Vehicle Mount??
    By CyberLaw in forum Motorola Xoom Accessories
    Replies: 102
    Last Post: 04-09-2011, 11:21 AM

Search tags for this page

can i connect my motorola xoom to my linux computer

,

connect motorola phone to ubuntu 12.04

,
connect storage android 4.1.1 ubuntu
,

connect xoom to ubuntu

,
fuse: bad mount point `/media/nexus/': transport endpoint is not connected
,
how detect storage android 4.1.1 in ubuntu
,
how to mount internal storage using linux
,
htc one x linux usb
,
motorola xoom 2 mz616 android sdcard vold.fstab mounting
,
motorola xoom 32gb wifi ubuntu
,
motorola xoom connect linux
,
motorola xoom internal mount points
,

motorola xoom mount points

,
mount htc one x usb storage ubuntu
,
mount motorola iden linux
,

mount motorola xoom ubuntu 12.04

,

mounting droid dna ubuntu

,
please mount internal storage before using the camera tablet
,
ubuntu 10.10 connect to android camera
,

usb mount xoom linux

Click on a term to search for related topics.

Tags for this Thread