• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Broken ICS media scanning service, interaction with MTP?

This is a discussion on Broken ICS media scanning service, interaction with MTP? within the Motorola Xoom General Discussion forums, part of the Motorola Xoom Forum category; Since updating my Xoom (32gb WiFi US) to the Motorola ICS push ... I've had a lot of problems with the media scanning service. Music ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Like Tree1Likes

Thread: Broken ICS media scanning service, interaction with MTP?

  1. #1
    Xoom Lurker
    Member #
    20072
    Join Date
    Jan 2012
    Posts
    11
    Liked
    0 times

    Angry Broken ICS media scanning service, interaction with MTP?

    Since updating my Xoom (32gb WiFi US) to the Motorola ICS push ... I've had a lot of problems with the media scanning service.
    1. Music & Video on the SDHC card either fail to be detected or are incompletely added to my media library (i.e. not or partially available in the stock music & video apps)
      • Partially remedied by running the free Scan Media app from the market
    2. Once media is loaded into the media database by the media scanning service, it is there stably for only a day or two, then I start getting "Couldn't play the track you requested" messages in the stock music player.
    3. When (2.) is observed, if I plug the Xoom into my Windows 7 box & look in the SDHC, there appears to be 3 (or more) duplicates of the directory on the SDHC that contains my music.
      • If I remove the SDHC and use a card reader, the music directory on the SDHC appears only once as expected.
    4. The only way to remedy (2.) and (3.) is go to Settings->Apps->All->Media Storage->Force stop->Clear data. Then I do a hard reset (Volume up + Power).
    What the heck is going on? Is the media scanning service seriously broken/fragile and/or is there a negative interaction with MTP?

    I understand that MTP is used in Honeycomb & ICS to allow the OS/Apps to co-exist on common partition/block device with data, but this is a serious problem. Not to mention, MTP is less than convenient on OSes other than Windows and it is SLOW to transfer data to the Xoom.

    Thanks for any help, advice, comments, commiseration. Cheers,

  2. # ADS
    Ads


  3. #2
    Xoom Operative
    Member #
    16138
    Join Date
    Nov 2011
    Posts
    243
    Liked
    13 times
    in /settings/apps/ clear the media storage data and googleservicesframework data and reboot
    then wait 20 minute and it should rescan your media

  4. #3
    Xoom Lurker
    Member #
    20072
    Join Date
    Jan 2012
    Posts
    11
    Liked
    0 times
    Thanks. I've tried that repeatedly. Unfortunately, within a day or two, the issue re-appears. I think the media scanning service is corrupting its own database. The appearance of multiple instances of my music directory when connected to my pc over MTP also suggests an interaction. Seems media scanning and MTP are buggy & fragile.

  5. #4
    Xoom Informant
    Member #
    3961
    Join Date
    Apr 2011
    Posts
    53
    Liked
    5 times
    I have also had a similar experience with my music files.
    All my music is on my Sd card, I haven't removed the SD card or altered any of the music on there for a number of weeks. I went to play some music through google music the other day and it gave the error message of "Couldn't play the track you requested". I have previously had this error message which was just after upgrading to ICS so I cleared the media storage data, rebooted and let the media scan find all my music files, this worked and enabled me to play the music on the SD card.
    However that was a number of weeks ago and yet only a few days ago I had the same error message when trying to play any of my music files. The only thing I have changed inbetween is a few reboots/switch off when I haven't been using the xoom.

    I would agree it looks like the media database has some form of corruption issues.
    Does anyone know a long term workaround for this?
    clearing the media storage data and waiting for a full rescan isn't much fun


    Thanks,
    ampoo likes this.

  6. #5
    Xoom Operative
    Member #
    16138
    Join Date
    Nov 2011
    Posts
    243
    Liked
    13 times
    Quote Originally Posted by ampoo View Post
    Thanks. I've tried that repeatedly. Unfortunately, within a day or two, the issue re-appears. I think the media scanning service is corrupting its own database. The appearance of multiple instances of my music directory when connected to my pc over MTP also suggests an interaction. Seems media scanning and MTP are buggy & fragile.
    did you clear the googleservicesframework data?

  7. #6
    Super Moderator

    Member #
    98
    Join Date
    Feb 2011
    Location
    Felton, PA
    Posts
    1,734
    Liked
    136 times
    Could this be an Android power saver feature that does the equivalent of spinning down the SD slot for power conservation?
    Bensode
    Debian, XOOM & Droid Enthusiast

  8. #7
    Xoom Lurker
    Member #
    20072
    Join Date
    Jan 2012
    Posts
    11
    Liked
    0 times
    I'll try this next.I'll post the result. Thanks!

  9. #8
    Xoom Lurker
    Member #
    20072
    Join Date
    Jan 2012
    Posts
    11
    Liked
    0 times
    I hope it's not a power saving "feature".

  10. #9
    Xoom Lurker
    Member #
    20072
    Join Date
    Jan 2012
    Posts
    11
    Liked
    0 times
    Quote Originally Posted by liftman View Post
    did you clear the googleservicesframework data?
    I've tried Apps->Media storage->Clear data + Apps->Google Frramework->Clear data + restart with volumne-up&power. Scanning still fails.

  11. #10
    Xoom Operative
    Member #
    16138
    Join Date
    Nov 2011
    Posts
    243
    Liked
    13 times
    I read while I was having a similar issue android doesn't get along with some cards, can you try another card for a few days?


 
Page 1 of 2 1 2 LastLast

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. my charger is broken
    By Ashkan2012 in forum Motorola Xoom Accessories
    Replies: 7
    Last Post: 02-24-2012, 02:58 AM
  2. Wifi is broken after 3.2 update
    By Severina in forum Motorola Xoom WiFi General Discussion
    Replies: 24
    Last Post: 01-10-2012, 11:22 AM
  3. Android is Broken:What can be done to fix it?
    By ggrant3876 in forum Off-Topic Forum
    Replies: 3
    Last Post: 11-17-2011, 04:21 PM
  4. [RECOVERY] Oh S... Please help fix broken xoom.
    By 4lex in forum Motorola Xoom Help
    Replies: 12
    Last Post: 11-14-2011, 09:58 PM
  5. {[HELP!]} Hammerhead = broken xoom
    By drocksmash in forum Xoom Rescue Squad Help
    Replies: 4
    Last Post: 09-08-2011, 07:39 AM

Search tags for this page

android ics force a media scan
,
android media scanner duplicates
,
android media storage scan
,
android reset media scanner
,
android xoom media scanner runs forever
,

couldn't play the track you requested

,
force media scan android
,
how can android media scanner get corrupt
,

ics media scan

,

ics media scanner

,
ics rescan media
,
media scan fix ics
,

media scanner service

,
media scanner service android
,
mtp database corruption android
,
play music couldnt play the music you requested
,

rescan media ics

,
reset media storage on thrive
,
restore media scanner in android
,
stop media scanner service
Click on a term to search for related topics.

Tags for this Thread