• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

first post. unfortunate news.. sent to repair for charging issues

This is a discussion on first post. unfortunate news.. sent to repair for charging issues within the Motorola Xoom General Discussion forums, part of the Motorola Xoom Forum category; Originally Posted by bayani919 Bestbuy was willing to give me a new xoom on the spot.. but I refused because I spent so much time ...

Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
  1. #11
    Technician X
    Member #
    792
    Join Date
    Mar 2011
    Posts
    2,065
    Liked
    174 times
    Quote Originally Posted by bayani919 View Post
    Bestbuy was willing to give me a new xoom on the spot.. but I refused because I spent so much time personalizing my interface with minamilistic text, etc.. I went with th one year repair service from moto instead ..

    I was using the flimsy charger and am going to invest in a dock now as someone mentioned above.. im very relieved on the input you guys mentioned of it not being a heating issue... they told me the turn around should be 5 to 7business days.. ill keep my fingers crossed
    Good luck! Unfortunately no one is perfect (except jeff bridges in the big lebowski) so were gunna have these issues occasionally

  2. # ADS
    Ads


  3. #12
    Xoom Informant
    Member #
    586
    Join Date
    Mar 2011
    Location
    41 4' 5" N / 72 20' 19" W
    Posts
    71
    Liked
    6 times
    Quote Originally Posted by bayani919 View Post
    ... they told me the turn around should be 5 to 7business days.. ill keep my fingers crossed
    Hey...on the bright side, maybe it'll come back with a working SD card and 4g! SuhhhWEEET ! LOL

  4. #13
    Xoom Informant
    Member #
    5985
    Join Date
    May 2011
    Posts
    57
    Liked
    1 times
    Quote Originally Posted by treyatl2006 View Post
    Why you just didnt get a replacement from Bestbuy. You have a 30 day return period. Or a 45 day return period if you are a silver reward member.
    My Xoom is also experiencing lousy charge times now ( battery shows ~ 40% after charging all night). I was under the impression that Best Buy only offered Exchange/Returns for the first 2 weeks? Best Buy Store Exchange & Return Policy - Best Buy Is there some other info you have access to, that shows different? I picked up the Xoom on May 5 (30 days ago)...

    Thanks
    Last edited by jdoo; 06-05-2011 at 10:55 AM.

  5. #14
    Xoom Conveyor
    Member #
    808
    Join Date
    Mar 2011
    Posts
    479
    Liked
    24 times
    You are right.. Its 14 days or 45 days for silver reward members. But sometimes they will exchange after 14 days if its a defect.

  6. #15
    Super Moderator

    Member #
    98
    Join Date
    Feb 2011
    Location
    Felton, PA
    Posts
    1,734
    Liked
    136 times
    Quote Originally Posted by bobjenkins View Post
    Good luck! Unfortunately no one is perfect (except jeff bridges in the big lebowski) so were gunna have these issues occasionally
    I watched rips on rocklplayer for about 12 hours straight (twice) on my train ride. It didn't heat up enough that I noticed it. Nearly every laptop I had would heat up noticeably after about an hour of watching movies.

    OT: Bob have you seen True Grit yet? Probably his second best, next to "The Dude" ...
    Bensode
    Debian, XOOM & Droid Enthusiast

  7. #16
    Xoom Operative
    Member #
    1417
    Join Date
    Mar 2011
    Location
    virginia
    Posts
    245
    Liked
    13 times
    I dont kno what i did but i can leave my xoom on sleep and wake it up 6 hrs later and have 97% battery.plus i gotcracked glass

  8. #17
    Xoom Informant
    Member #
    1796
    Join Date
    Mar 2011
    Posts
    41
    Liked
    1 times
    I've been having some charging issues myself, I usually plug it in nightly, and one morning i woke up with zero charge, re-seated the plug and got a charge, but every once in a while when i plug the charger in, it just won't recognize that it's on power. I have not tried a replacement charger or a dock yet.

    Oh and to the OP.... You most likely should have just taken the one from BB, in my experience, when you send a unit in for a "repair" they are either going to wipe your unit and send it back fresh, or send you a refurb unit and keep yours to repair later and then send out to someone else when they send theirs in. I'd call moto back again and specifically request that you get your original unit back.
    Last edited by mhochman; 06-06-2011 at 07:09 AM.

  9. #18
    Xoom Lurker
    Member #
    5829
    Join Date
    May 2011
    Posts
    5
    Liked
    0 times
    I had these kind of issues- replaced the charger and still continued. Turned out that both chargers couldn't work OK with the four-way mains power adaptor that I was using! Connecting the charger directly to the mains wall socket solved the problem!

    Sent from my MZ601 using Tapatalk

  10. #19
    Xoom Lurker
    Member #
    7200
    Join Date
    Jun 2011
    Posts
    6
    Liked
    0 times
    Update:
    .. on a good note, motorola has received my Xoom today, and finished repair and shipped it out as well! Everything was updated to me via email. A fedex tracking #shows its shipping from Illinois to me (california) with delivery date for tomorrow.Much quicker than I expected. The repair updates on the moto website didn't say anything of what was wrong with the unit, or details as to what exactly was fixed/repaired. I'm pretty sure its the same unit because they emailed me giving the same meid#, I could be wrong though, I'll post tomorrow when I get it arrives to confirm. All in all I'm just happy its fixed, looking forward to some battleheart since they updated it!

  11. #20
    Xoom Lurker
    Member #
    7200
    Join Date
    Jun 2011
    Posts
    6
    Liked
    0 times
    Oh... and they also shipped me an extra charger, I guess if this happens to anyone else, call them and tell them to ship you a charger first to test it out and they will... free charger for my troubles..cant complain I guess


 
Page 2 of 3 FirstFirst 1 2 3 LastLast

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Charging issues
    By kfxo in forum Motorola Xoom Help
    Replies: 19
    Last Post: 08-01-2011, 01:40 PM
  2. No charging LED with 3.1?
    By Beemer533 in forum Motorola Xoom General Discussion
    Replies: 9
    Last Post: 05-15-2011, 10:50 AM
  3. a Google rep should post here with insider news sometimes...
    By Slam in forum Motorola Xoom General Discussion
    Replies: 7
    Last Post: 04-22-2011, 11:19 PM
  4. Charging the Xoom
    By Zammo in forum Motorola Xoom General Discussion
    Replies: 21
    Last Post: 04-15-2011, 10:29 PM
  5. Charging
    By Bill Blasic in forum Motorola Xoom Help
    Replies: 3
    Last Post: 04-08-2011, 01:17 PM

Search tags for this page

how to fix motorola xoom charge
,
how to fix motorola xoom charger
,
motorola xoom charger problem
,

motorola xoom charger problems

,
motorola xoom charging issues
,
motorola xoom charging port repair
,
motorola xoom charging port replacement
,
motorola xoom charging port replacement part
,
motorola xoom charging problem
,

motorola xoom charging problems

,
motorola xoom problems with charger port
,
motorola xoom repair
,
problem charging motorolla xoom
,
problems with motorola xoom charging
,
repair xoom charging port
,
trouble with motorola xoom charging
,
xoom charger problems
,
xoom charging issues
,
xoom charging problem
,
xoom faulty charger
Click on a term to search for related topics.

Tags for this Thread