• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

Motorola xoom Mz604

This is a discussion on Motorola xoom Mz604 within the Motorola Xoom Help forums, part of the Motorola Xoom Support Forum category; Hi, Im new and this is going to be a long one. So one day I accidently fell my tablet on the carpet floor. And ...

Results 1 to 1 of 1
  1. #1
    Xoom Lurker
    Member #
    29464
    Join Date
    Sep 2013
    Posts
    1
    Liked
    0 times

    Motorola xoom Mz604

    Hi, Im new and this is going to be a long one. So one day I accidently fell my tablet on the carpet floor. And now it wouldn't charge unless I put it in a certain angle so it can reach connection. Btw the light takes time to turn on about 5 seconds after I plug it in with the charger on that certain angle. Now I went to my friends house and ran out of batteries. I ordered a dock before I went to his house. Now I can't tell whether it's charging or not because it takes secs for the light to come on and the angle is SUPER CERTAIN. So I was stuck. But I got impatient and began pressing vol + and pwr button to turn it on. (while it still had 0 battery left.) It went on for a couple a secs. I thought I could get the angle before it turned back off. I tried this a couple of times until about the 5th try it went black and wouldn't turn on. NO MATTER WHAT I DID. Vol+ pwr or vol- pwr button I tried both volume buttons and power. No luck. I read on some posts some people held the pwr button and clicked the vol + for some time. I tried this and it did not work. After the dock came I plugged it in. And it still wouldn't charge. I was little mad. So I started venturing for days how to fix this and all people said was 'Did you try the button combination?' It kinda pissed me off how people repeatedly said this having the problem clearly stated no soft reset would work. But then some guy said to tear down fix. I did it and put it back together. Nothing happened. Nothing changed. I'm sad right now cause nothing is working and I don't have enough money to replace the xoom. I talked to Motorola they said they can't do anything. But they said something about charger connector port loose? so I hang on to that hope. So once again I took it apart and im leaving the battery out for an hour. I saw some post said to do this. I'm writing this post while the battery is still out. Any help? I tried screwing in every screw inside trying to tighten it. I assumed the worst that it was bricked so I searched online how to unbrick. and every single one said to turn it on EVERY SINGLE ONE SAID TO TURN IT ON TO THE MOTOROLA LOGO. Understanding that I CANNOT turn it on AT ALL. My last hope is to post this thread hoping someone knows whats the problem.

  2. # ADS
    Ads



 

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. How to upgrade Canadian Motorola Xoom MZ604 to official US Android stock firmware
    By LeoKac in forum Non U.S. Xoom General Discussion
    Replies: 2
    Last Post: 09-15-2013, 04:41 AM
  2. Motorola XOOM MZ604
    By ilyabyk83 in forum Motorola Xoom WiFi General Discussion
    Replies: 12
    Last Post: 02-19-2013, 09:00 AM
  3. Where To Obtain Service For My Motorola XOOM MZ604 tablet.
    By Lorne in forum Non U.S. Motorola Xoom Help
    Replies: 2
    Last Post: 08-22-2012, 03:48 AM
  4. Motorola Xoom MZ604
    By halleycool in forum Motorola Xoom General Discussion
    Replies: 2
    Last Post: 08-21-2012, 05:19 AM
  5. Unroot Motorola Xoom wifi MZ604
    By zalsayegh in forum Motorola Xoom Development
    Replies: 5
    Last Post: 07-06-2011, 06:37 AM

Search tags for this page

motorola mz604 change volumn

,

motorola xoom mz604

,

mz604 battery

,

xoommz604 charger

Click on a term to search for related topics.