• Login:

Welcome to the Xoom Forum - Motorola Xoom Forum.

Register ButtonIf this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

.9.png problem

This is a discussion on .9.png problem within the Motorola Xoom Themes forums, part of the Motorola Xoom Hacks category; i follow bazars guide on doing the .9.png files but everytime the module either fcs or fails to load or if it does work then ...

Results 1 to 6 of 6

Thread: .9.png problem

  1. #1
    Xoom Informant
    Member #
    11372
    Join Date
    Aug 2011
    Location
    Maryland, USA
    Posts
    81
    Liked
    2 times

    .9.png problem

    i follow bazars guide on doing the .9.png files but everytime the module either fcs or fails to load or if it does work then it doesnt look right. what i did was take bazars red theme (thanks for the layout to help me quickly identify images used) and photoshop them to be blue instead. then i take the pngs and place them in the folder described and run the script in dos command. then i move them from done folder back to normal folder. then i make 2 copies of the orginal apk and alter 1 in 7zip by dragging over the new images i altered. then i apply the zip via recovery and then it has problems. i can do the normal png files without problem as ive done alot of those already and applied just fine. trying to figure what i am doing wrong. ive made the blue look pretty nice so far and thanks bazar for the guide and red theme for the headstart.

    running hammerhead and tachi kernel. sample of whats done some of it, quick screenshot of my settings, still got alot more to change in the framework but got rest done except the keyboard.

    P20110828174707.jpg

  2. # ADS
    Ads


  3. #2
    Theme Developer

    Member #
    448
    Join Date
    Mar 2011
    Posts
    2,204
    Liked
    290 times
    Twitter
    Bazar6
    ROMs
    1 Submitted
    Themes
    37 Submitted
    The blue looks good dude.

    Trying to get a hold of whats going wrong... Are you modifying my theme? Or just used my theme as a reference and are theming a stock version? You have to decompile the apk in APKmanager, which will extract everything and put it in its rawest format. You'll see black lines along the edges for .9s. This is what you have to edit, when it's in this form.

    Then compile your edited file in Draw9Patch or xUltimate, and drop that compiled image in to your themed apk. The compiled version will not have the black lines around it.

    Let me know if this clears anything up or if you're still havin problems.

  4. #3
    Xoom Informant
    Member #
    11372
    Join Date
    Aug 2011
    Location
    Maryland, USA
    Posts
    81
    Liked
    2 times
    its obviously decompiled if i got majority blue . im using your theme as reference. now you say suppose to be black border around image and i dont recall seeing one when i opened it in photoshop, ill double check this. ive had png files opened that the whole background is black, sadly saves it this way too, but i left those for later to figure out. right now im digging thru the xml files and got some changes in mind for some of the displayed items, gonna tinker with it and see what happens.

    if there isnt a black border would it just easy to draw one in? any special requirements for this border?

    So looked at some on my .9.png and heres what I see
    Before compile:
    default_widget_preview.9.png

    After:
    default_widget_preview.9.png

    Kinda odd how its sorta purple but when i compile it goes blue. Now I do see the black border sorta but only in spots, not whole image. is there suppose to be border around whole image?
    Last edited by tiger62651; 09-07-2011 at 08:13 PM.

  5. #4
    Xoom Informant
    Member #
    11372
    Join Date
    Aug 2011
    Location
    Maryland, USA
    Posts
    81
    Liked
    2 times
    Still haven't figured out the .9.png file yet but mucking with the xml files looky what i did w00t.

    device-2011-09-08-225043.jpg

    able to get text color changed, working on clock and need lighter blue for text, to hard to see difference. thought i had it light enough but guess not. mucked with the Setting Quick panel but kept FCing on me so need to figure this out. thanks for the great xml guide, although needs major update. 1st need Android SDK with API 13. Then copy the aapt.exe from android sdk folder and place it in the apktool folder. then you'll be able to compile 3.2 apk's. had many problems trying 2nd method but figured it out.

  6. #5
    Theme Developer

    Member #
    448
    Join Date
    Mar 2011
    Posts
    2,204
    Liked
    290 times
    Twitter
    Bazar6
    ROMs
    1 Submitted
    Themes
    37 Submitted
    Quote Originally Posted by tiger62651 View Post
    its obviously decompiled if i got majority blue . im using your theme as reference. now you say suppose to be black border around image and i dont recall seeing one when i opened it in photoshop, ill double check this. ive had png files opened that the whole background is black, sadly saves it this way too, but i left those for later to figure out. right now im digging thru the xml files and got some changes in mind for some of the displayed items, gonna tinker with it and see what happens.

    if there isnt a black border would it just easy to draw one in? any special requirements for this border?

    So looked at some on my .9.png and heres what I see
    Before compile:
    default_widget_preview.9.png

    After:
    default_widget_preview.9.png

    Kinda odd how its sorta purple but when i compile it goes blue. Now I do see the black border sorta but only in spots, not whole image. is there suppose to be border around whole image?
    I have never drawn in the black border, mostly because you gotta guess where it is, because the black lines dictate what is going to be stretched. If it doesn't have a black border, then make sure it really is a .9. Sometimes it gets a little picky. And those two images, the one with black around it is the decompiled .9 that you need, the black line does not go ALL the way around the border, just in places where it needs to stretch. After is correctly compiled, yes. but your last sentence, I don't see any difference in the colors, and they should never be a different color when they are compiled.

    Quote Originally Posted by tiger62651 View Post
    Still haven't figured out the .9.png file yet but mucking with the xml files looky what i did w00t.

    device-2011-09-08-225043.jpg

    able to get text color changed, working on clock and need lighter blue for text, to hard to see difference. thought i had it light enough but guess not. mucked with the Setting Quick panel but kept FCing on me so need to figure this out. thanks for the great xml guide, although needs major update. 1st need Android SDK with API 13. Then copy the aapt.exe from android sdk folder and place it in the apktool folder. then you'll be able to compile 3.2 apk's. had many problems trying 2nd method but figured it out.
    Yea I need to update the guide to be specific to 3.2, I wrote it during 3.1. I've updated the links tho since 3.2 needed a new APKtool. I'm sorry you've had issues with it. What is the blue picture with yellow arrows for tho?

  7. #6
    Xoom Informant
    Member #
    11372
    Join Date
    Aug 2011
    Location
    Maryland, USA
    Posts
    81
    Liked
    2 times
    pix with yellow arrows is showing off what i did in the xmls. turned all that text blue, today got better color and digging thru all the xmls and seeing the linkage going on i found something thats gonna speed my color change quickly, if it works ill post guide.

    Update:

    It worked for what I did HAHA, now gotta find rest of the colors. As soon as I find all the colors will post guide how to alter them all at once rather than 1 xml file at a time. Most blue letter i altered 2 files which covers all system texts that point to that file. If you also haven't noticed that battery % has been spaced more from the icon, will post where and how to move that later.

    1.jpg2.jpg3.jpg

    If you want full sized pictures http://www.tigerznet.com/xoom click there
    Last edited by tiger62651; 09-10-2011 at 11:49 AM.


 

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. hi, me again with another problem
    By busymom in forum Motorola Xoom Help
    Replies: 2
    Last Post: 08-28-2011, 06:51 PM
  2. I think i have a problem...
    By hobojoe196061 in forum Motorola Xoom General Discussion
    Replies: 3
    Last Post: 07-15-2011, 07:02 AM
  3. first big problem
    By bensode in forum Motorola Xoom Help
    Replies: 7
    Last Post: 04-23-2011, 09:35 AM
  4. Odd problem.....
    By MI22 in forum Motorola Xoom WiFi Tablet Help
    Replies: 3
    Last Post: 04-11-2011, 04:46 PM
  5. i have a problem
    By xXTheHaunted in forum Off-Topic Forum
    Replies: 9
    Last Post: 03-19-2011, 09:14 AM

Search tags for this page

.9 not work android
,

.9 png

,
.9 png black line red line
,
.9 png problems
,
9 png problem
,
9.png android not working
,

9.png bug

,
9.png in layout xml issue
,

android .9 png

,
android 9.png layout bug
,
android 9.png line
,
android 9.png not show
,
android 9.png not work
,

compile 9.png

,

default widget preview.9.png

,
how to compile .9 pngs
,

how to compile .9.png

,
how to edit .9 pngs
,

motorola xoom png

,
spacing problems with motorola xoom
Click on a term to search for related topics.